Description
已之一个圆的半径,求面积. 提示PI=3.1415
Input
输入有多行,第一行是一个整数n(对应总行数),以下每一行只有一个浮点数(对应一个圆的半径).
Output
输出有多行,每一行是跟输入对应面积. 输出保留6位小数
Sample Input
4
3.14
2.13
6
5.3
Sample Output
30.973933
14.252671
113.094000
88.244735
float类型的数据是有精度的,精度外的数据是不准确的
double比float精度高,但依然有精度
float是小数加止整数后6位是准确的,而double则会更才一些
#include<stdio.h>
#include<stdlib.h>
#define PI 3.1415
void main()
{
float *p;
int n;
scanf("%d",&n);
p=(float *)malloc(sizeof(float)*n);
for(int i=0;i<n;i++)
scanf("%f",&p[i]);
for(i=0;i<n;i++)
printf("%.6f\n",p[i]*p[i]*PI);
free(p);
}
C语言,float x=3.14,计算x*x(3.14*3.14=9.8596),实际计算出来为什么等于9...
float类型的数据是有精度的,精度外的数据是不准确的 double比float精度高,但依然有精度 float是小数加止整数后6位是准确的,而double则会更才一些 include<stdio.h> include<stdlib.h> define PI 3.1415 void main(){ float *p;int n;scanf("%d",&n);p=(float *)malloc(sizeof(float)*n...