编程高手赐教,,C语言,求x+y,x-y 。。。。

Description
计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。

Input
输入只有一行,格式见sample。

Output
输出为多行,按顺序每行输出x,y的和、差、积、商、余数、x的平方和y的三次方,格式见sample

Sample Input
x = 11, y = 3

Sample Output
x + y : 14
x - y : 8
x * y : 33
x / y quotient: 3, remainder: 2
x ^ 2 : 121
y ^ 3 : 27

HINT

注意输入输出格式。了解C语言整数除法运算符的特点,并且没有求幂的运算符。
顺便帮我把程序写出来

C语言有求幂函数z=pow(x, y);z等于x的y次方。

#include <math.h>
温馨提示:内容为网友见解,仅供参考
第1个回答  2011-10-14
#include <stdio.h>
#include <stdlib.h>
int main( )
{
int x,y;
scanf("x = %d, y = %d",&x,&y);
printf("x + y : %d\n",x+y);
printf("x - y : %d\n",x-y);
printf("x * y : %d\n",x*y);
printf("x / y quotient: %d, remainder: %d\n",x/y,x%y);
printf("x ^ 2 : %d\n",x*x);
printf("y ^ 3 : %d\n",y*y*y);
//system("pause");/*要看是否准确就加*/
return 0;
}
我测过了,100%准确本回答被提问者采纳
第2个回答  2011-10-14
123

关于商人过河的问题,c语言
额 这个有点难搞

【紧急】求C语言编程高手帮忙、急~这是一个下拉菜单的程序、但是我的...
中毒

编程高手请进!(C语言)
include <stdio.h> include<stdlib.h> include<ctype.h> main(){ int count;\/*猜数字的次数*\/ int number;\/*系统产生的随机数字*\/ int guess;\/*程序员输入数字*\/ char yes='Y';clrscr();printf("\\nNow let us play the game.\\n Guess the number:");while (toupper(yes)=='Y'){...

C语言编程,字母转换
b Y c 输出:ZaYbZ 希望能帮助你哈^_^

求这个C程序的编程怎么弄!!!谢谢高手
include <stdio.h>int main(){ float x, y; printf("请输入长方形的长和宽:"); scanf("%f%f", &x, &y); printf("the length=%f,the width=%f\\n", x, y); printf("The area=%f\\n", x*y); return 0;}

出钱求c语言编程高手 题目:有n个点,坐标(x1,y1)...(xn,yn),这n个点...
下面给出一个程序,其中以权值差的绝对值取代“权值差”。假设这n个点的横坐标、纵坐标、权值分别存放在数组double X[n], Y[n], P[n]中,现用一个函数来求所需数据。所需函数及一个调用实例如下:include<stdio.h> include<math.h> double GetResult(double *X, double *Y, double *P, ...

用C语言编程,求X的Y次方(不用POW,用指针)
include<stdio.h> int main(){ int x,y,i,fac=1;int *p;scanf("%d%d",&x,&y);p=&x;for(i=1;i<=y;i++){ fac*=*p;\/\/计算X的Y次方 if(y==0)fac=1;} printf("%d",fac);}

急!急!急!请高手帮忙编写一个C语言的单片机编程。。要能通过的...
int main(){ int n,i,j;while(1){ printf("Enter n(1-4):");scanf("%d",&n);switch(n){ case 1:{ for(i=1;i<=N;i++){ for(j=N-i;j>=0;j--) printf(" ");for(j=1;j<=i*2-1;j++) printf("*");printf("\\n");} break;} case 2:{ for(i=1;i<=N;i...

电脑C语言编程,求高手帮忙
1.include<stdio.h> void main(){ int n[8],maxn=0,minn=0,detn;float score[8],max,min,aver=0.0,det,detm;printf("输入裁判号及分数:\\n");scanf("%d%f",&n[0],&score[0]);max=min=score[0];for(int i=1;i<8;i++){ scanf("%d%f",&n[i],&score[i]);if(max<...

一道C语言问题,请各位高手们帮一下。
int x1=30,x2=40;void sub(int x,int y){ x1=x;x=y;y=x1; \/\/ x,y值 交换,并且x1=x ,由于没有 返回值, 所以只有 那个 \/\/全局 变量x1的 值 保留了下来}void main(){ int x3=10,x4=20; sub(x3,x4); \/\/ x1=x3=10 , sub(x2,x1); \/\/ \/\/ x1=x2=40 , \/\/ 最后结果x2...

相似回答