如何实现同一路由器不同vlan之间的通信

如题所述

1.单臂路由(图)
环境:一台路由器,一台二层交换机,两台pc机

二层交换机的配置
一般模式:
Switch>
输入enable进入特权模式:
Switch>enable
输入configure terminal进入全局配置模式:
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
创建vlan 10 和 vlan 20:
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)# exit
进入接口配置模式:
Switch(config)#interface fastEthernet 0/1
把0/1变成trunk口(默认是access口)
Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch(config-if)#exit
进入接口配置模式分别把对应的接口,加入对应的vlan:
Switch(config)#interface fastEthernet 1/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastEthernet 2/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
到此而层交换机配置完毕!
路由器的配置:
Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter fas 0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
注意:单臂路由的配置父接口一定要no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int fas 0/0.10
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
Router(config-subif)#encapsulation dot1Q 10
注意:在配置ip时一定要先封装802.1q协议
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#int fas 0/0.20
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#
查看路由表:
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, FastEthernet0/0.10
C 192.168.20.0/24 is directly connected, FastEthernet0/0.20
Router#
PC0的配置:
ip 192.168.10.10
netmask 255.255.255.0
gateway 192.168.10.1
PC1的配置:
ip 192.168.20.20
netmask 255.255.255.0
gateway 192.168.20.1
2.使用SVI实现VLAN间的通信(图)
环境:一台三层交换机,两台pc机

三层交换机的配置:
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
创建vlan 10 20
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit
配置SVI接口ip
Switch(config)#interface vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#interface vlan 20
%LINK-5-CHANGED: Interface Vlan20, changed state to up
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
改变接口模式并加入vlan
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
Switch(config-if)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
Switch(config-if)#
看三层交换机的路由表:
Switch#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, Vlan10
C 192.168.20.0/24 is directly connected, Vlan20
Switch#
两主机的配置与单臂路由中两主机的配置一样
3.跨交换机实现VLAN间的通信(图)
环境:一台三层交换机,两台二层交换机,两台pc机

三层交换机的配置(SW3)
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
创建vlan 10 、 20 并设置ip
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#exit
Switch(config)#interface vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up
Switch(config-if)#ip address 192.168.10.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#interface vlan 20
%LINK-5-CHANGED: Interface Vlan20, changed state to up
Switch(config-if)#ip address 192.168.20.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
设置接口模式并加入相应的vlan(注意trunk口的设置)
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#interface fastEthernet 0/1
Switch(config-if)#switchport access vlan 10
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 20
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
Switch#
看路由表
Switch#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, Vlan10
C 192.168.20.0/24 is directly connected, Vlan20
SW21的配置
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch(config-if)#interface fastEthernet 1/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#
SW22的配置
Switch>
Switch>en
Switch#
Switch#configure ter
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#inter fas 1/1
Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/1, changed state to up

Switch(config-if)#switchport mode access
Switch(config-if)#inter fas 2/1
Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/1, changed state to up

Switch(config-if)#exit
Switch(config)#vlan 20
Switch(config-vlan)#inter fas 1/1
Switch(config-if)#switchport access vlan 20
Switch(config-if)#
注意:两交换机之间的链接是trunk链路
4.以上配置在模拟器上都可实现
在模拟器上配置其中pc图片
上述三种方式pc机的配置都一样
温馨提示:内容为网友见解,仅供参考
第1个回答  2016-11-25
不用实现,有路由就能通。本回答被提问者采纳

同一网段,不同vlan,为什么能ping通?什么原理?
一种可能的情况是,网络中存在三层交换设备或路由器,这些设备能够识别VLAN标签,并根据路由表将数据包从一个VLAN转发到另一个VLAN。当不同VLAN的主机位于同一网段时,如果它们之间配置了正确的网关,那么这些主机就可以通过网关进行通信。在这种情况下,ping操作实际上是通过网关进行的,而不是直接在两个VL...

H3C:路由实现不同VLAN通信(方法二)
1. 开启计算机并进入配置界面。配置接口,为每台设备分配静态IP地址。2. 使用HCL(H3C Cloud Lab)软件启动交换机与路由器。通过双击设备或右键启动命令行配置终端。3. 在交换机配置界面,执行命令以实现不同VLAN间的通信。命令解释为:启用VLAN功能,配置VLAN ID,创建VLAN接口,并设置相应的IP地址与子...

不同vlan怎么互通
第三种:三层交换技术 一台三层交换机既可以实现将终端隔离在不同的 VLAN 中,同时位这些终端提供 VLAN 间路由的功能,不需要再借助路由器来转发不同 VLAN 之间的流量。

如何利用路由器实现不同VLAN之间通信
利用路由器实现不同VLAN之间通信的具体操作如下:⒈在同一个交换机上创建VLAN1、VLAN2两个不同的VLAN,将端口5和端口10分别分配到两个VLAN中(确保VLAN1、VLAN2所连设备的IP地址在不同的网段上);⒉在交换机的快速以太网端口配置模式(SX (config-if) #)下,键入trunk on命令,打开trunk功能;⒊在路由...

一个路由器两个vlan如何设置可以相互通信如图!
回答:路由器的二个端口分别接入VLAN1、2,设置端口IP分别是VLAN子网内某一IP VLAN内电脑网关使用路由器端口IP。 查看路由器路由选择表应该有VLAN1,VLAN2路由信息。

同一个交换机之间不同vlan怎么互通?
处理方法:1、将SW1和SW2间的互联链路设置成trunk,并allow-pass vlan all;2、删除SW1的 ip route-static 192.168.0.0 255.255.0.0 192.168.99.2命令,直接用默认路由指到SW2的IP即:ip route-static 0.0.0.0 0.0.0.0 192.168.99.23、在SW2上做静态路由,实现vlan间互通:ip ...

路由器是怎样实现Vlan之间通信?
在使用路由器实现不同Vlan通信时

如何实现不同 VLAN 之间的相互通信?
我先建立两个VLAN,再让两个不同的VLAN间通信;指令如下:首先在switch0中建立 Swith>en Swith#conf t Switch(config)#vlan 2 Switch(config-vlan)#exit Switch(config)#vlan 3 Switch(config-vlan)#exit Switch(config)#int fa0\/2 Switch(config-if)#switchport access vlan 2 Switch(config-if...

同一局域网不同网段怎么互通
通过测试结果可以看出,在三层交换机的状态下,通过vlan的方式可以实现不同网段的IP地址互通。方式二:通过路由器实现不同网段的通信 对于不具备配置vlan功能的普通交换机,我们可以选择使用路由器来实现不同网段的通信。这种方式需要路由器支持多端口lan地址配置。具体实现步骤如下:1. 同样为PC1和PC2配置...

不同vlan之间如何互相访问
不同vlan之间通过使用路由器实现互相访问。1、处于不同VLAN的计算机即使是在同一交换机上,vlan之间的通信也必须使用路由器。每个VLAN上都有一个以太网口和路由器连接,要实现不同VLAN间的通信,则路由器需要多个以太网接口,同时占用了多个交换上的以太网接口。2、VLAN间的通信需要借助第三层设备,可以...

相似回答