大神,请教一道C语言题目:调用自定义函数search(int list[], int n),在数组中查找某个数

Description
输入10个整数存储到数组a,再输入一个整数x,在数组a中查找x,若找到则输出相应的下标,否则显示"Not found"。要求定义和调用函数search(int list[], int n, int x),在数组list中查找元素x,若找到则返回相应下标,否则返回-1.
Input
多组测试数据,每组先输入10个整数,再输入一个x
Output
输出x在数组中的下标或"Not found"
Sample Input
1 2 3 4 5 6 7 8 9 10 5
1 2 3 4 5 6 7 8 9 10 20

Sample Output
4
Not found

HINT

#include<stdio.h>
#include<string.h>
#define N 20
int arr[N];


int search(int list[], int n, int x){

int i;
for(i = 1; i <= n; ++i)
if(list[i] == x)
return i;

return -1;
}

int main(){ 

int i, x, tmp;
while(1){
for(i = 1; i <= 10; ++i)
scanf("%d", arr+i);
scanf("%d", &x);

tmp = search(arr, N, x);
if(tmp > 0)
printf("%d\n", tmp - 1);
else
printf("Not found\n");
}
return 0;
}

追问

运行起来是对的,但是交上去说“Running and Jogging”

最终结果是Output Limit Exceed

追答

把while循环去掉

追问

谢谢

温馨提示:内容为网友见解,仅供参考
无其他回答
相似回答